Modding Inquisition
Status
Back
Maintenance
Updating maven
Completed 12 Jan at 10:15pm EET.
Affected services
maven.moddinginquisition.org
Completed
Maintenance completed
Posted 12 Jan at 10:15pm EET.
Started
We're updating our maven
Posted 12 Jan at 10:05pm EET.